Genealogy Chat

Top tip - using the Genes Reunited community

Welcome to the Genes Reunited community boards!

  • The Genes Reunited community is made up of millions of people with similar interests. Discover your family history and make life long friends along the way.
  • You will find a close knit but welcoming group of keen genealogists all prepared to offer advice and help to new members.
  • And it's not all serious business. The boards are often a place to relax and be entertained by all kinds of subjects.
  • The Genes community will go out of their way to help you, so don’t be shy about asking for help.

Quick Search

Single word search

New Scottish Census

New Scottish census records

Do you have Scottish ancestors?

Perhaps you do and you just didn't know! Search our brand new Scottish census records today and discover if you have Scottish roots.

Search Scottish Census

Icons

  • New posts
  • No new posts
  • Thread closed
  • Stickied, new posts
  • Stickied, no new posts

Family search

ProfilePosted byOptionsPost Date

Winterose

Winterose Report 17 May 2013 14:01

Hi All

Family Search issue now sorted Chrome browser working a real treat!
Thanks all, next time i'll know to try another browser.

Nice weekend all :))
kathy

Tenerife Sun

Tenerife Sun Report 17 May 2013 11:42

Not working with Safari just constantly says loading, but never gets there.

Winterose

Winterose Report 17 May 2013 11:03

Thanks all, yes its working now that i've changed browser, works with E & F but not C

So happy now :))

KenSE

KenSE Report 17 May 2013 10:44

I am on IE9.

Rambling Rose

Rambling Rose Report 17 May 2013 10:40

Just switched from Chrome to IE and it's working on that ok.

Winterose

Winterose Report 17 May 2013 10:36

Yes!! KenSE :))

KenSE

KenSE Report 17 May 2013 10:26

We are talking this one aren't we?

https://www.familysearch.org/

Edit: I've tried three different searches and they all gave expected results.

Treehunter

Treehunter Report 17 May 2013 10:23

Not working here what ever way I go into it. I am just getting a blank page. :-(

Rambling Rose

Rambling Rose Report 17 May 2013 10:18

Not working for me either,

Winterose

Winterose Report 17 May 2013 10:18

I'm glad its not just my computer! Can hardly wait for it to sort out!! -what a pain!!

Thanks all :))
Kathy

KenSE

KenSE Report 17 May 2013 10:16

Are you using an old link or favourite?

KenSE

KenSE Report 17 May 2013 10:05

It's working for me.

What appears to be the problem?

Winterose

Winterose Report 17 May 2013 09:51

Hello all

Is Family Search down or is it my computer?

Cheers Kathy