Top tip - using the Genes Reunited community

Welcome to the Genes Reunited community boards!

  • The Genes Reunited community is made up of millions of people with similar interests. Discover your family history and make life long friends along the way.
  • You will find a close knit but welcoming group of keen genealogists all prepared to offer advice and help to new members.
  • And it's not all serious business. The boards are often a place to relax and be entertained by all kinds of subjects.
  • The Genes community will go out of their way to help you, so don’t be shy about asking for help.

Quick Search

Single word search

Genes Extras

Genes Reunited subscription bonuses

As a way of saying thank you to our subscribers, we have launched Genes Extras. You'll find exclusive competitions and discounts on family history magazines, days out and much more.

Take me to Genes Extras


  • New posts
  • No new posts
  • Thread closed
  • Stickied, new posts
  • Stickied, no new posts

Cannot add to tree

ProfilePosted byOptionsPost Date


Sue Report 14 Aug 2012 20:19

Now when adding to my tree, when i enter place of birth or place of marriage, and it says place unknown, and will not save it.
Can anyone help, or if not will write again to GR.

Thank you Sue


Sue Report 12 Aug 2012 12:37

It was suggested to me (when i contacted GR direct) that the browser i was using was old, and to update free, one of four choices, one of which was Google Chrome. Which i did.
As i said in a previous post, for those who have not got the latest computers, there will be problems.


Eleanor Report 10 Aug 2012 11:48

...Also my messages don't seem to come up with the 'new post' icon. Why is that?



Eleanor Report 10 Aug 2012 11:41

I've also had problems updating family members. I can't scroll down the details on my iPad and sometimes when I add details and press save I get the message that everything is updating (green bars across screen) but then nothing is changed. Also, I can't edit details when I use the home computer unless I open GR in google chrome...which I can't always do, but that's a different problem!


William Report 9 Aug 2012 21:52

I've tried fiddling with compatability but I still can't add a child of my relative.

William Russell Jones


SylviaInCanada Report 8 Aug 2012 00:34

NO-ONE should have to update their browser, or use another browser, to use a site.

That is GR fobbing you off!

Keep on complaining to them via the address



+++DetEcTive+++ Report 7 Aug 2012 22:33

Thanks for the update :-)


Sue Report 7 Aug 2012 22:31

Just to let people know, GR replied saying i needed to update my browser and having done that, i managed to add someone to my tree, but it was very slow and tedious.
For heavens sake, why didnt GR tell people that in the first place. We are not all computer whizz kids. I had to have help to do that anyway.
It seems that if you havent got the newest up to the minute computer, then hard luck.



Sue Report 7 Aug 2012 11:40

Thanks DetEcTive
I have written to GR directly, last evening, so far no reply.
Yes, this did happen after the recent changes.

Regards, Sue


+++DetEcTive+++ Report 6 Aug 2012 20:52

If this has only happened since the most recent changes, best to contact

or use the 'contact us' from the 'Help' link at the top of the page.


Sue Report 6 Aug 2012 19:36

I have tried on several occasions to add to my tree, but screen just goes pale.
Is anyone else having this problem, ? If not will write direct to Genes, I have just about had as much as i can take from this incompetent lot.

thanks, Sue.