Genealogy Chat

Top tip - using the Genes Reunited community

Welcome to the Genes Reunited community boards!

  • The Genes Reunited community is made up of millions of people with similar interests. Discover your family history and make life long friends along the way.
  • You will find a close knit but welcoming group of keen genealogists all prepared to offer advice and help to new members.
  • And it's not all serious business. The boards are often a place to relax and be entertained by all kinds of subjects.
  • The Genes community will go out of their way to help you, so don’t be shy about asking for help.

Quick Search

Single word search


  • New posts
  • No new posts
  • Thread closed
  • Stickied, new posts
  • Stickied, no new posts

ProfilePosted byOptionsPost Date

Teresa With Irish Blood in Me Veins

Teresa With Irish Blood in Me Veins Report 14 Mar 2020 15:20

I can't get on to the website. The website address I usually use keeps failing.

Can any one give me the correct info please?


ArgyllGran Report 14 Mar 2020 15:56

No, I get the "Secure Connection Failed" message, too.

It has a Facebook page - seems to have a lot of downtime, per messages there;


Aha! I clicked on the link at the bottom of the Secure Connection Failed message - says something about "enable TLS1 " - something like that (can't remember) - and it worked!

Now when I click on the link you gave (or any other link) , the website opens immediately.

And now that I can see the website, it seems, from messages on there, that it's a Firefox problem, and yes, you do have to enable TLS - whatever that is.


nameslessone Report 14 Mar 2020 16:14

Is it something to do with Firefox?


ArgyllGran Report 14 Mar 2020 16:15

Yes, I've just added that to my last post.

Teresa With Irish Blood in Me Veins

Teresa With Irish Blood in Me Veins Report 14 Mar 2020 18:03

Ok. Thanks for you help. Much appreciated.


malyon Report 14 Mar 2020 21:41

i just clicked on the link it was ok


SylviaInCanada Report 15 Mar 2020 23:52

I've just logged in using my Bookmark link, and it worked fine.