Genealogy Chat

Top tip - using the Genes Reunited community

Welcome to the Genes Reunited community boards!

  • The Genes Reunited community is made up of millions of people with similar interests. Discover your family history and make life long friends along the way.
  • You will find a close knit but welcoming group of keen genealogists all prepared to offer advice and help to new members.
  • And it's not all serious business. The boards are often a place to relax and be entertained by all kinds of subjects.
  • The Genes community will go out of their way to help you, so don’t be shy about asking for help.

Quick Search

Single word search


  • New posts
  • No new posts
  • Thread closed
  • Stickied, new posts
  • Stickied, no new posts

GSP Family tree maker.

ProfilePosted byOptionsPost Date


Kevin Report 8 Feb 2021 11:23

Ive used GSP family tree maker since 2005 and what a wonderful thing it is. However its stopped responding and trying to find a solution for an I.T. Phoebe is not easy. I even tried to reload the original disc hoping it would re start the original with years of work on it, or in the worse case scenario allow me to re-enter it all from the latest printout i have on my wall. Im afraid to go randomly pressing keys maybe deleting altogether if its still intact somewhere in the deep and darkest confines within my PC. Any replies appreciated but remember you're talking to someone with limited computer skills ! Thanks Kevin Bolden

Shirley~I,m getting the hang of it

Shirley~I,m getting the hang of it Report 8 Feb 2021 11:57

What is GSP family tree maker?


ErikaH Report 8 Feb 2021 12:08

A computer program


ArgyllGran Report 8 Feb 2021 12:21

I know absolutely nothing about GSP FTM, Kevin.

However, having Googled it (have you tried that?), a couple of thoughts occur:

Maybe see if it needs a new driver ??
See the first post on page 2 of this thread:

Or maybe try restoring your computer's system to a date before FTM stopped working ??

Info here about FTM support:

And here - see also the messages and replies at the end of the article:

"Family Tree Maker 2005 - Fix Your Not Responding Program Now"


Inky1 Report 8 Feb 2021 12:33

Your tree data is surely stored somewhere on your pc. But it may not be as a gedcom (.ged) file.
I suggest that you first look in the GSP directories. If you find a .ged - or something that looks like one - copy it to another area then try opening that copy with 'Notepad' or some other text editor.


nameslessone Report 8 Feb 2021 13:06

I had a problem with FTM of a similar date.

You will find your data is usually so stored in My Documents. Make sure you have a back up copy of this.

Using another computer my OH used a slightly more upto date version of FTM and copied the data. It worked so did it again on the machine I usually use.


Inky1 Report 8 Feb 2021 16:34

Not stated is what machine this FTM is running on. Surely not a 16 year old pc?

The following is probably of little or no help. It seems that ownership of this title has changed hands - maybe more than once.

part of a blog...
Hi John I researched the global software publishing limited and they were bought out by a company call avanquest. I searched for an update so you could simple transfer the info but as you can see from this link they only offer new versions of the family tree. Please look at this link: I have located the tech support for your product specifically which may help on this link you will see a circle which is yellow and white and has GSP (global software publishing) in the center, and then you will see yes or no to register perhaps if you register with them they will give you a link to transfer your current tree to a newer version. I am sorry I couldn't be more helpful here but the company product you were using no longer exists.

I went to gspsupport co. uk and this appeared to be selling software and follow up on said software as required. This is of no help as I do not know what software I need.

This is exactly what I explained in my last post. There is no updated software for you family tree program that company no longer exists.

Google "avanquest"
Avanquest Software Publishing Ltd
The principal activity of the company is the publishing of multimedia software products.
Software & Tech Services
Unit A Meadow Lane St Ives United Kingdom